FabricationConfiguration Class

This element contains the information about the fabrication configuration settings used by the project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBFabricationConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationConfiguration : Element

The FabricationConfiguration type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyCode exampleBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCode exampleCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCode exampleDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyCode exampleDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyCode exampleGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyCode exampleId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyCode exampleLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyCode exampleParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyCode exampleParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyCode exampleUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodAncillaryExists Checks to see if the specified ancillary exists.
Public methodAreItemFilesLoaded Checks if the fabrication item files have been loaded.
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanBeSwapped Checks if the fabrication configuration can be swapped.
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodCanUnloadItemFiles Checks if the fabrication item files are already in use and should not be unloaded.
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodCheckConnectionsForAllFabricationParts Checks the connections for all fabrication parts in the current project. It will create reviewable warnings for all bad connections found. The checks are looking for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Public methodCustomDataExists Checks to see if the specified custom data exists.
Public methodDamperExists Checks to see if the specified damper exists.
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public methodGetAllDampers Gets all damper identifiers in the fabrication configuration.
Public methodGetAllFabricationConnectorDefinitions Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public methodGetAllInsulationSpecifications Gets all insulation specification identifiers in the fabrication configuration.
Public methodGetAllLoadedItemFiles Get list of all loaded fabrication item files.
Public methodGetAllLoadedServices Returns all the loaded fabrication services.
Public methodGetAllMaterials Gets all material identifiers in the fabrication configuration.
Public methodGetAllPartCustomData Gets all possible fabrication part custom data identifiers.
Public methodGetAllPartStatuses Gets all possible fabrication part status identifiers.
Public methodGetAllServices Returns all fabrication services in the fabrication configuration.
Public methodGetAllSpecifications Gets all specification identifiers in the fabrication configuration.
Public methodGetAllUsedItemFiles Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public methodGetAllUsedServices Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public methodGetAncillaries Gets fabrication ancillaries of the specified type.
Public methodGetAncillaryGroup Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public methodGetAncillaryGroupName Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public methodGetAncillaryName Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public methodGetDamperName Gets the damper name from its identifier.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodStatic memberGetFabricationConfiguration Gets the fabrication configuration element in the document.
Public methodGetFabricationConfigurationInfo Gets the information about the fabrication configuration of the project.
Public methodGetFabricationConnectorDomain Gets the fabrication connector domain from its identifier.
Public methodGetFabricationConnectorGroup Gets the fabrication connector group from its identifier.
Public methodGetFabricationConnectorName Gets the fabrication connector name from its identifier.
Public methodGetFabricationConnectorShape Gets the fabrication connector shape from its identifier.
Public methodCode exampleGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetInsulationSpecificationAbbreviation Gets insulation specification abbreviation.
Public methodGetInsulationSpecificationGroup Gets the insulation specification group from its identifier.
Public methodGetInsulationSpecificationName Gets the insulation specification name from its identifier.
Public methodGetItemFolders Gets a list of fabrication item folders in the fabrication item folder structure.
Public methodGetMaterialAbbreviation Gets the abreviation of the material or the insulation or the double wall material.
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialByGUID Gets the material identifier by its GUID.
Public methodGetMaterialGaugeByGUID Gets the material gauge identifier by its GUID and material identifier.
Public methodGetMaterialGaugeGUID Gets the material gauge GUID by its material/gauge identifiers.
Public methodGetMaterialGroup Gets material group from its identifier.
Public methodGetMaterialGUID Gets the material GUID by its identifier.
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialName Gets material name from its identifier.
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPartCustomDataName Gets the custom data name from its identifier.
Public methodGetPartCustomDataType Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public methodGetPartStatusDescription Gets the status description from its identifier.
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetProfile Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public methodGetService Get the service based on the service identifier from the fabrication configuration in the current document.
Public methodGetServiceByGUID Gets the service identifier by its GUID.
Public methodGetServiceGUID Gets the service GUID by its identifier.
Public methodGetServiceTypeName Gets the service type name.
Public methodGetSpecificationAbbreviation Gets specification abbreviation.
Public methodGetSpecificationByGUID Gets the specification identifier by its GUID.
Public methodGetSpecificationGroup Gets the specification group from its identifier.
Public methodGetSpecificationGUID Gets the specification GUID by its identifier.
Public methodGetSpecificationName Gets the specification name from its identifier.
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodCode exampleGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetUpdatedStraightsFromValidateConnections Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodHasValidConfiguration Checks whether a valid fabrication configuration has been set for the project.
Public methodIsAncillaryKit Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLoadItemFiles Loads the specified fabrication item files into the project.
Public methodLoadServices Loads the specified fabrication services into the project.
Public methodLocateFabricationConnector Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public methodLocateInsulationSpecification Gets the insulation specification by group and name.
Public methodLocateMaterial Gets material by group and name.
Public methodLocateSpecification Gets the specification identifier by group and name.
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodPostReviewableWarningsForBadConnections Reviewable warnings are created for all entries contained in the connection validation information.
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodReloadConfiguration Reloads the fabrication configuration from its source fabrication configuration.
Public methodSetConfiguration(FabricationConfigurationInfo) Set the fabrication configuration with global profile.
Public methodSetConfiguration(FabricationConfigurationInfo, String) Set the fabrication configuration with specific profile.
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetServicesToLoad Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Public methodUnloadItemFiles Unload the specified fabrication item files from the project.
Public methodUnloadServices Unload the specified fabrication services from the project.
Public methodValidateConnectionsForAllFabricationParts Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Top
Remarks
The element provides information about the location of the fabrication database, its properties, and settings related to fabrication items.
See Also