FabricationConfiguration Class

This element contains the information about the fabrication configuration settings used by the project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBFabricationConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationConfiguration : Element

The FabricationConfiguration type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodAncillaryExists Checks to see if the specified ancillary exists.
Public methodAreItemFilesLoaded Checks if the fabrication item files have been loaded.
Public methodCanBeSwapped Checks if the fabrication configuration can be swapped.
Public methodCanUnloadItemFiles Checks if the fabrication item files are already in use and should not be unloaded.
Public methodCheckConnectionsForAllFabricationParts Checks the connections for all fabrication parts in the current project. It will create reviewable warnings for all bad connections found. The checks are looking for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Public methodCustomDataExists Checks to see if the specified custom data exists.
Public methodDamperExists Checks to see if the specified damper exists.
Public methodGetAllDampers Gets all damper identifiers in the fabrication configuration.
Public methodGetAllFabricationConnectorDefinitions Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public methodGetAllInsulationSpecifications Gets all insulation specification identifiers in the fabrication configuration.
Public methodGetAllLoadedItemFiles Get list of all loaded fabrication item files.
Public methodGetAllLoadedServices Returns all the loaded fabrication services.
Public methodGetAllMaterials Gets all material identifiers in the fabrication configuration.
Public methodGetAllPartCustomData Gets all possible fabrication part custom data identifiers.
Public methodGetAllPartStatuses Gets all possible fabrication part status identifiers.
Public methodGetAllServices Returns all fabrication services in the fabrication configuration.
Public methodGetAllSpecifications Gets all specification identifiers in the fabrication configuration.
Public methodGetAllUsedItemFiles Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public methodGetAllUsedServices Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public methodGetAncillaries Gets fabrication ancillaries of the specified type.
Public methodGetAncillaryGroup Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public methodGetAncillaryGroupName Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public methodGetAncillaryName Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public methodGetDamperName Gets the damper name from its identifier.
Public methodStatic memberGetFabricationConfiguration Gets the fabrication configuration element in the document.
Public methodGetFabricationConfigurationInfo Gets the information about the fabrication configuration of the project.
Public methodGetFabricationConnectorDomain Gets the fabrication connector domain from its identifier.
Public methodGetFabricationConnectorGroup Gets the fabrication connector group from its identifier.
Public methodGetFabricationConnectorName Gets the fabrication connector name from its identifier.
Public methodGetFabricationConnectorShape Gets the fabrication connector shape from its identifier.
Public methodGetInsulationSpecificationAbbreviation Gets insulation specification abbreviation.
Public methodGetInsulationSpecificationGroup Gets the insulation specification group from its identifier.
Public methodGetInsulationSpecificationName Gets the insulation specification name from its identifier.
Public methodGetItemFolders Gets a list of fabrication item folders in the fabrication item folder structure.
Public methodGetMaterialAbbreviation Gets the abreviation of the material or the insulation or the double wall material.
Public methodGetMaterialByGUID Gets the material identifier by its GUID.
Public methodGetMaterialGaugeByGUID Gets the material gauge identifier by its GUID and material identifier.
Public methodGetMaterialGaugeGUID Gets the material gauge GUID by its material/gauge identifiers.
Public methodGetMaterialGroup Gets material group from its identifier.
Public methodGetMaterialGUID Gets the material GUID by its identifier.
Public methodGetMaterialName Gets material name from its identifier.
Public methodGetPartCustomDataName Gets the custom data name from its identifier.
Public methodGetPartCustomDataType Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public methodGetPartStatusDescription Gets the status description from its identifier.
Public methodGetProfile Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public methodGetService Get the service based on the service identifier from the fabrication configuration in the current document.
Public methodGetServiceByGUID Gets the service identifier by its GUID.
Public methodGetServiceGUID Gets the service GUID by its identifier.
Public methodGetServiceTypeName Gets the service type name.
Public methodGetSpecificationAbbreviation Gets specification abbreviation.
Public methodGetSpecificationByGUID Gets the specification identifier by its GUID.
Public methodGetSpecificationGroup Gets the specification group from its identifier.
Public methodGetSpecificationGUID Gets the specification GUID by its identifier.
Public methodGetSpecificationName Gets the specification name from its identifier.
Public methodGetUpdatedStraightsFromValidateConnections Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.
Public methodHasValidConfiguration Checks whether a valid fabrication configuration has been set for the project.
Public methodIsAncillaryKit Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public methodLoadItemFiles Loads the specified fabrication item files into the project.
Public methodLoadServices Loads the specified fabrication services into the project.
Public methodLocateFabricationConnector Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public methodLocateInsulationSpecification Gets the insulation specification by group and name.
Public methodLocateMaterial Gets material by group and name.
Public methodLocateSpecification Gets the specification identifier by group and name.
Public methodPostReviewableWarningsForBadConnections Reviewable warnings are created for all entries contained in the connection validation information.
Public methodReloadConfiguration Reloads the fabrication configuration from its source fabrication configuration.
Public methodSetConfiguration(FabricationConfigurationInfo) Set the fabrication configuration with global profile.
Public methodSetConfiguration(FabricationConfigurationInfo, String) Set the fabrication configuration with specific profile.
Public methodSetServicesToLoad Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public methodUnloadItemFiles Unload the specified fabrication item files from the project.
Public methodUnloadServices Unload the specified fabrication services from the project.
Public methodValidateConnectionsForAllFabricationParts Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Top
Remarks
The element provides information about the location of the fabrication database, its properties, and settings related to fabrication items.
See Also