FabricationConfigurationGetAllSpecifications Method |
Gets all specification identifiers in the fabrication configuration.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetAllSpecifications(
FabricationPart part
)
Public Function GetAllSpecifications (
part As FabricationPart
) As IList(Of Integer)
public:
IList<int>^ GetAllSpecifications(
FabricationPart^ part
)
member GetAllSpecifications :
part : FabricationPart -> IList<int>
Parameters
- part FabricationPart
-
The fabrication part.
Return Value
IListInt32
An array of specification identifiers.
Remarks
If a part is passed, only returns specifications which are valid for the part, otherwise returns all specifications.
See Also