ElementGetMaterialVolume Method |
Gets the volume of the material with the given id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetMaterialVolume(
ElementId materialId
)
Public Function GetMaterialVolume (
materialId As ElementId
) As Double
public:
double GetMaterialVolume(
ElementId^ materialId
)
member GetMaterialVolume :
materialId : ElementId -> float
Parameters
- materialId ElementId
-
The material id returned from GetMaterialIds(Boolean).
Return Value
Double
The volume of the material for this element. Returns 0.0 if the material is not a part of this element.
Exceptions
See Also