ElementGetValidTypes Method |
Obtains a set of types that are valid for this element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetValidTypes()
Public Function GetValidTypes As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetValidTypes()
member GetValidTypes : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
A set of element IDs of types that are valid for this element or an empty set if element cannot have type assigned.
See Also