ElementGetMaterialIds Method |
Gets the element ids of all materials present in the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetMaterialIds(
bool returnPaintMaterials
)
Public Function GetMaterialIds (
returnPaintMaterials As Boolean
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetMaterialIds(
bool returnPaintMaterials
)
member GetMaterialIds :
returnPaintMaterials : bool -> ICollection<ElementId>
Parameters
- returnPaintMaterials Boolean
-
If true, this returns material ids assigned to element faces by the Paint tools. If false, this returns ids associated to the material through
its geometry or compound structure layers.
Return Value
ICollectionElementId
The set of material ids.
Remarks
The returned collection of materials will be empty in any of the following situations:
- The returnPaintMaterials flag is false, and the Category.HasMaterialQuantities property of the element's Category is false.
- The returnPaintMaterials flag is true, and the the element does not have any painted faces.
Any material ids returned by this method can be used in GetMaterialArea() to get the calculated area associated to the material.
Non-paint materials ids returned by this method can be used in GetMaterialVolume() to get the volume associated to the material.
See Also