ElementGetOrderedParameters Method |
Gets the parameters associated to the element in order.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Parameter> GetOrderedParameters()
Public Function GetOrderedParameters As IList(Of Parameter)
public:
IList<Parameter^>^ GetOrderedParameters()
member GetOrderedParameters : unit -> IList<Parameter>
Return Value
IListParameter
A collection containing all parameters.
RemarksThe collection consists of only visible parameters associated to the element; it returns a different list than Element.Parameters.
The parameters are returned in the order in which they appear in the Revit UI within a given group;
however, parameters of different groups may be mixed within this output.
Currently the Revit UI order is determined first by group and next by the order of the individual parameters.
See Also