ElementParameter(Definition) Property

Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Parameter this[
	Definition definition
] { get; }

Parameters

definition  Definition
The internal or external definition of the parameter.

Property Value

Parameter
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.
See Also