ElementGetDependentElements Method |
Get all elements that, from a logical point of view, are the children of this Element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> GetDependentElements(
ElementFilter filter
)
Public Function GetDependentElements (
filter As ElementFilter
) As IList(Of ElementId)
public:
IList<ElementId^>^ GetDependentElements(
ElementFilter^ filter
)
member GetDependentElements :
filter : ElementFilter -> IList<ElementId>
Parameters
- filter ElementFilter
-
What type of elements we are interested of.
Can be NULL to return all dependent elements.
Return Value
IListElementId
Logical children of this element
RemarksThe elements that this method will return:
- Will be deleted if the input Element is deleted.
- Potentially could report the input Element as a host (there could be other type of
parent/child relationship here: for example view/view-specific elements, etc.)
See Also