ElementDesignOption Property |
Returns the design option to which the element belongs.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DesignOption DesignOption { get; }
Public ReadOnly Property DesignOption As DesignOption
Get
public:
property DesignOption^ DesignOption {
DesignOption^ get ();
}
member DesignOption : DesignOption with get
Property Value
DesignOption
RemarksIf the element is not in a design option, i.e. in the main model, then this property will
return .
Examplevoid Getinfo_DesignOption(Document document)
{
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
foreach (ElementId id in selectedIds)
{
Element element = document.GetElement(id);
if (element.DesignOption != null)
{
TaskDialog.Show("Revit",element.DesignOption.Name.ToString());
}
}
}
Private Sub Getinfo_DesignOption(document As Document)
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
For Each id As ElementId In selectedIds
Dim element As Element = document.GetElement(id)
If element.DesignOption IsNot Nothing Then
TaskDialog.Show("Revit", element.DesignOption.Name.ToString())
End If
Next
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also