FabricationConfigurationValidateConnectionsForAllFabricationParts Method |
Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ConnectionValidationInfo ValidateConnectionsForAllFabricationParts(
bool updateGapForStraights
)
Public Function ValidateConnectionsForAllFabricationParts (
updateGapForStraights As Boolean
) As ConnectionValidationInfo
public:
ConnectionValidationInfo^ ValidateConnectionsForAllFabricationParts(
bool updateGapForStraights
)
member ValidateConnectionsForAllFabricationParts :
updateGapForStraights : bool -> ConnectionValidationInfo
Parameters
- updateGapForStraights Boolean
-
Attempt to update straights to remove the gap between the connctors.
Return Value
ConnectionValidationInfo
The information about the validation check.
Exceptions
Remarks
See Also