ElementGetExternalResourceReferences Method |
Gets the map of the external resource references referenced
by the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<ExternalResourceType, ExternalResourceReference> GetExternalResourceReferences()
Public Function GetExternalResourceReferences As IDictionary(Of ExternalResourceType, ExternalResourceReference)
public:
IDictionary<ExternalResourceType^, ExternalResourceReference^>^ GetExternalResourceReferences()
member GetExternalResourceReferences : unit -> IDictionary<ExternalResourceType, ExternalResourceReference>
Return Value
IDictionaryExternalResourceType,
ExternalResourceReference
The map of the external resource references referenced by the element.
Exceptions
Remarks
For an element which has multiple external resource references
under a specified type like AppearanceAssetElement, the first one will be the value in the map.
See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferencesExpanded].
See Also