Element Class

Base class for most persistent data within a Revit document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Element : IDisposable

The Element type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
Public propertyCode exampleBoundingBoxRetrieves a box that circumscribes all geometry of the element.
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
Public propertyCode exampleCreatedPhaseId Id of a Phase at which the Element was created.
Public propertyCode exampleDemolishedPhaseId Id of a Phase at which the Element was demolished.
Public propertyCode exampleDesignOptionReturns the design option to which the element belongs.
Public propertyDocumentReturns the Document in which the Element resides.
Public propertyCode exampleGeometryRetrieves the geometric representation of the element.
Public propertyGroupId The id of the group to which an element belongs.
Public propertyCode exampleId A unique identifier for an Element in an Autodesk Revit project.
Public propertyIsModifiable Identifies if the element is modifiable.
Public propertyIsTransient Indicates whether an element is transient or permanent.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLevelId The id of the level associated with the element.
Public propertyCode exampleLocationThis property is used to find the physical location of an element within a project.
Public propertyNameA human readable name for the Element.
Public propertyOwnerViewId The id of the view that owns the element.
Public propertyCode exampleParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
Public propertyCode exampleParametersRetrieves a set containing all of the parameters that are contained within the element.
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
Public propertyPinned Identifies if the element has been pinned to prevent changes.
Public propertyCode exampleUniqueId A stable unique identifier for an element within the document.
Public propertyVersionGuid Get the element version Guid.
Public propertyViewSpecific Identifies if the element is owned by a view.
Public propertyWorksetId Get Id of the Workset which owns the element.
Top
Methods
 NameDescription
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
Public methodCanBeLocked Identifies if the element can be locked.
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
Public methodStatic memberCanHaveTypeAssigned(Document, ICollectionElementId) Checks if all elements in the set can have a type assigned.
Public methodChangeTypeId(ElementId) Changes the type of the element.
Public methodStatic memberChangeTypeId(Document, ICollectionElementId, ElementId) Changes the type of all elements in the given set.
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
Public methodDeleteSubelement Removes a subelement from the element.
Public methodDeleteSubelements Removes the subelements from the element.
Public methodDisposeReleases all resources used by the Element
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
Public methodEvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
Public methodStatic memberGetChangeTypeAny Returns ChangeType associated with any change in an element.
Public methodStatic memberGetChangeTypeElementAddition Returns ChangeType associated with element addition
Public methodStatic memberGetChangeTypeElementDeletion Returns ChangeType associated with element deletion.
Public methodStatic memberGetChangeTypeGeometry Returns ChangeType associated with a change in the geometry of an element
Public methodStatic memberGetChangeTypeParameter(ElementId) Returns ChangeType associated with a change in a parameter's value
Public methodStatic memberGetChangeTypeParameter(Parameter) Returns ChangeType associated with a change in a parameter's value
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
Public methodCode exampleGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
Public methodGetMaterialArea Gets the area of the material with the given id.
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
Public methodGetMaterialVolume Gets the volume of the material with the given id.
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
Public methodGetParameterRetrieves a parameter from the element given identifier.
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Public methodGetParametersRetrieves the parameters from the element via the given name.
Public methodGetPhaseStatus Gets the status of a given element in the input phase
Public methodGetSubelements Returns the collection of element subelements.
Public methodCode exampleGetTypeId Returns the identifier of this element's type.
Public methodGetValidTypes Obtains a set of types that are valid for this element.
Public methodStatic memberGetValidTypes(Document, ICollectionElementId) Obtains a set of types that are valid for all given elements.
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
Public methodIsExternalFileReference Determines whether this Element represents an external file.
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
Public methodStatic memberIsValidType(Document, ICollectionElementId, ElementId) Checks if given type is valid for the set of elements.
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Top
Remarks
The data in a Revit document consists primarily of a collection of elements. An element usually corresponds to a single component of a building or drawing, such as a wall, door, or dimension, but it can also be something more abstract, like a wall type or a view. Every element in a document has a unique ID, represented by the ElementId class.
See Also
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.AnalysisAnalysisDisplayLegend
    Autodesk.Revit.DB.AnalysisAnalysisDisplayStyle
    Autodesk.Revit.DB.AnalysisBuildingOperatingDaySchedule
    Autodesk.Revit.DB.AnalysisBuildingOperatingYearSchedule
    Autodesk.Revit.DB.AnalysisConceptualSurfaceType
    Autodesk.Revit.DB.AnalysisEnergyAnalysisConstruction
    Autodesk.Revit.DB.AnalysisEnergyAnalysisDetailModel
    Autodesk.Revit.DB.AnalysisEnergyAnalysisMaterial
    Autodesk.Revit.DB.AnalysisEnergyAnalysisOpening
    Autodesk.Revit.DB.AnalysisEnergyAnalysisSpace
    Autodesk.Revit.DB.AnalysisEnergyAnalysisSurface
    Autodesk.Revit.DB.AnalysisEnergyAnalysisWindowType
    Autodesk.Revit.DB.AnalysisEnergyAnalysisZone
    Autodesk.Revit.DB.AnalysisEnergyDataSettings
    Autodesk.Revit.DB.AnalysisGenericZone
    Autodesk.Revit.DB.AnalysisHVACLoadType
    Autodesk.Revit.DB.AnalysisMassLevelData
    Autodesk.Revit.DB.AnalysisMassSurfaceData
    Autodesk.Revit.DB.AnalysisPathOfTravel
    Autodesk.Revit.DB.AnalysisRouteAnalysisSettings
    Autodesk.Revit.DB.AnalysisSpatialFieldManager
    Autodesk.Revit.DBAppearanceAssetElement
    Autodesk.Revit.DB.ArchitectureContinuousRail
    Autodesk.Revit.DB.ArchitectureMultistoryStairs
    Autodesk.Revit.DB.ArchitectureRailing
    Autodesk.Revit.DB.ArchitectureStairs
    Autodesk.Revit.DB.ArchitectureStairsLanding
    Autodesk.Revit.DB.ArchitectureStairsPath
    Autodesk.Revit.DB.ArchitectureStairsRun
    Autodesk.Revit.DB.ArchitectureTopographySurface
    Autodesk.Revit.DBAreaScheme
    Autodesk.Revit.DBAreaVolumeSettings
    Autodesk.Revit.DBAssemblyInstance
    Autodesk.Revit.DBBaseArray
    Autodesk.Revit.DBBasePoint
    Autodesk.Revit.DBBeamSystem
    Autodesk.Revit.DBColorFillLegend
    Autodesk.Revit.DBColorFillScheme
    Autodesk.Revit.DBCombinableElement
    Autodesk.Revit.DBComponentRepeater
    Autodesk.Revit.DBComponentRepeaterSlot
    Autodesk.Revit.DBConnectorElement
    Autodesk.Revit.DBControl
    Autodesk.Revit.DBCurveElement
    Autodesk.Revit.DBDatumPlane
    Autodesk.Revit.DBDefaultDivideSettings
    Autodesk.Revit.DBDesignOption
    Autodesk.Revit.DBDimension
    Autodesk.Revit.DBDirectShape
    Autodesk.Revit.DBDisplacementElement
    Autodesk.Revit.DBDisplacementPath
    Autodesk.Revit.DBDividedPath
    Autodesk.Revit.DBDividedSurface
    Autodesk.Revit.DB.ElectricalAreaBasedLoadType
    Autodesk.Revit.DB.ElectricalCableTrayConduitRunBase
    Autodesk.Revit.DB.ElectricalCableTraySettings
    Autodesk.Revit.DB.ElectricalCableTraySizes
    Autodesk.Revit.DB.ElectricalCircuitNamingScheme
    Autodesk.Revit.DB.ElectricalCircuitNamingSchemeSettings
    Autodesk.Revit.DB.ElectricalConduitSettings
    Autodesk.Revit.DB.ElectricalConduitSizeSettings
    Autodesk.Revit.DB.ElectricalElectricalAnalyticalLoadSet
    Autodesk.Revit.DB.ElectricalElectricalAnalyticalNode
    Autodesk.Revit.DB.ElectricalElectricalDemandFactorDefinition
    Autodesk.Revit.DB.ElectricalElectricalLoadClassification
    Autodesk.Revit.DB.ElectricalElectricalSetting
    Autodesk.Revit.DB.ElectricalPanelScheduleSheetInstance
    Autodesk.Revit.DB.ElectricalPanelScheduleTemplate
    Autodesk.Revit.DBElementType
    Autodesk.Revit.DBElevationMarker
    Autodesk.Revit.DBExportDGNSettings
    Autodesk.Revit.DBExportDWGSettings
    Autodesk.Revit.DBExportPDFSettings
    Autodesk.Revit.DB.ExtensibleStorageDataStorage
    Autodesk.Revit.DBFabricationConfiguration
    Autodesk.Revit.DBFabricationPart
    Autodesk.Revit.DBFabricationServiceSettings
    Autodesk.Revit.DBFaceSplitter
    Autodesk.Revit.DBFamily
    Autodesk.Revit.DBFilledRegion
    Autodesk.Revit.DBFillPatternElement
    Autodesk.Revit.DBFilterElement
    Autodesk.Revit.DBGraphicsStyle
    Autodesk.Revit.DBGroup
    Autodesk.Revit.DBHostObject
    Autodesk.Revit.DBIFCCategoryTemplate
    Autodesk.Revit.DBImageInstance
    Autodesk.Revit.DBIndependentTag
    Autodesk.Revit.DBInstance
    Autodesk.Revit.DBInternalOrigin
    Autodesk.Revit.DBKeyBasedTreeEntryTable
    Autodesk.Revit.DBLinePatternElement
    Autodesk.Revit.DBMaterial
    Autodesk.Revit.DB.MechanicalDuctSettings
    Autodesk.Revit.DB.MechanicalDuctSizeSettings
    Autodesk.Revit.DB.MechanicalMechanicalEquipmentSet
    Autodesk.Revit.DB.MechanicalMEPAnalyticalSystem
    Autodesk.Revit.DB.MechanicalMEPHiddenLineSettings
    Autodesk.Revit.DB.MechanicalZone
    Autodesk.Revit.DB.MechanicalZoneEquipment
    Autodesk.Revit.DBMEPSystem
    Autodesk.Revit.DBModelText
    Autodesk.Revit.DBMultipleValuesIndicationSettings
    Autodesk.Revit.DBMultiReferenceAnnotation
    Autodesk.Revit.DBMultiSegmentGrid
    Autodesk.Revit.DBNestedFamilyTypeReference
    Autodesk.Revit.DBNumberingSchema
    Autodesk.Revit.DBNumberSystem
    Autodesk.Revit.DBOpening
    Autodesk.Revit.DBParameterElement
    Autodesk.Revit.DBPart
    Autodesk.Revit.DBPartMaker
    Autodesk.Revit.DBPhase
    Autodesk.Revit.DBPhaseFilter
    Autodesk.Revit.DB.PlumbingPipeSettings
    Autodesk.Revit.DBPrintSetting
    Autodesk.Revit.DBProjectInfo
    Autodesk.Revit.DBPropertyLine
    Autodesk.Revit.DBPropertySetElement
    Autodesk.Revit.DBReferencePoint
    Autodesk.Revit.DBRevision
    Autodesk.Revit.DBRevisionCloud
    Autodesk.Revit.DBRevisionNumberingSequence
    Autodesk.Revit.DBRevisionSettings
    Autodesk.Revit.DBScheduleSheetInstance
    Autodesk.Revit.DBSegment
    Autodesk.Revit.DBSheetCollection
    Autodesk.Revit.DBSketchBase
    Autodesk.Revit.DBSketchPlane
    Autodesk.Revit.DBSpatialElement
    Autodesk.Revit.DBSpatialElementCalculationLocation
    Autodesk.Revit.DBSpatialElementTag
    Autodesk.Revit.DBSSEPointVisibilitySettings
    Autodesk.Revit.DBStartingViewSettings
    Autodesk.Revit.DB.StructureAnalyticalElement
    Autodesk.Revit.DB.StructureAnalyticalLink
    Autodesk.Revit.DB.StructureAnalyticalToPhysicalAssociationManager
    Autodesk.Revit.DB.StructureAreaReinforcement
    Autodesk.Revit.DB.StructureBoundaryConditions
    Autodesk.Revit.DB.StructureFabricArea
    Autodesk.Revit.DB.StructureFabricSheet
    Autodesk.Revit.DB.StructureHub
    Autodesk.Revit.DB.StructureLoadBase
    Autodesk.Revit.DB.StructureLoadCase
    Autodesk.Revit.DB.StructureLoadCombination
    Autodesk.Revit.DB.StructureLoadNature
    Autodesk.Revit.DB.StructureLoadUsage
    Autodesk.Revit.DB.StructurePathReinforcement
    Autodesk.Revit.DB.StructureRebar
    Autodesk.Revit.DB.StructureRebarContainer
    Autodesk.Revit.DB.StructureRebarCoupler
    Autodesk.Revit.DB.StructureRebarInSystem
    Autodesk.Revit.DB.StructureReinforcementSettings
    Autodesk.Revit.DB.StructureStructuralConnectionHandler
    Autodesk.Revit.DB.StructureStructuralConnectionSettings
    Autodesk.Revit.DB.StructureStructuralSettings
    Autodesk.Revit.DB.StructureTruss
    Autodesk.Revit.DBSunAndShadowSettings
    Autodesk.Revit.DBTextElement
    Autodesk.Revit.DBView
    Autodesk.Revit.DBViewNavigationToolSettings
    Autodesk.Revit.DBViewport
    Autodesk.Revit.DBViewSheetSet
    Autodesk.Revit.DBWorksetDefaultVisibilitySettings
    Autodesk.Revit.DBWorksharingDisplaySettings