ElementRefersToExternalResourceReference Method

Determines whether this Element uses external resources associated with a specified external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool RefersToExternalResourceReference(
	ExternalResourceType resourceType
)

Parameters

resourceType  ExternalResourceType
The desired external resource type.

Return Value

Boolean
Returns true if this Element uses external resources associated with the specified external resource type; otherwise, false.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also