FabricationConfigurationGetAllMaterials Method |
Gets all material identifiers in the fabrication configuration.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetAllMaterials(
FabricationPart part
)
Public Function GetAllMaterials (
part As FabricationPart
) As IList(Of Integer)
public:
IList<int>^ GetAllMaterials(
FabricationPart^ part
)
member GetAllMaterials :
part : FabricationPart -> IList<int>
Parameters
- part FabricationPart
-
The fabrication part.
Return Value
IListInt32
An array of material identifiers.
Remarks
If a part is passed, only returns materials which are valid for the part, otherwise returns all materials.
See Also