FabricationConfigurationLocateFabricationConnector Method |
Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int LocateFabricationConnector(
string group,
string name,
ConnectorDomainType domain,
ConnectorProfileType shape
)
Public Function LocateFabricationConnector (
group As String,
name As String,
domain As ConnectorDomainType,
shape As ConnectorProfileType
) As Integer
public:
int LocateFabricationConnector(
String^ group,
String^ name,
ConnectorDomainType domain,
ConnectorProfileType shape
)
member LocateFabricationConnector :
group : string *
name : string *
domain : ConnectorDomainType *
shape : ConnectorProfileType -> int
Parameters
- group String
-
The fabrication connector group.
- name String
-
The fabrication connector name.
- domain ConnectorDomainType
-
ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
- shape ConnectorProfileType
-
ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.
Return Value
Int32
Return the fabrication connector identifier. Returns -1 if not found.
Exceptions
See Also