ElementIsPhaseDemolishedValid Method |
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsPhaseDemolishedValid(
ElementId demolishedPhaseId
)
Public Function IsPhaseDemolishedValid (
demolishedPhaseId As ElementId
) As Boolean
public:
bool IsPhaseDemolishedValid(
ElementId^ demolishedPhaseId
)
member IsPhaseDemolishedValid :
demolishedPhaseId : ElementId -> bool
Parameters
- demolishedPhaseId ElementId
-
The id of a Phase or invalidElementId.
Return Value
Boolean
True if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element, false otherwise.
Exceptions
Remarks
Acts as a validator for setting the property DemolishedPhaseId.
See Also