ElementGetParameterFormatOptions Method |
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FormatOptions GetParameterFormatOptions(
ElementId parameterId
)
Public Function GetParameterFormatOptions (
parameterId As ElementId
) As FormatOptions
public:
FormatOptions^ GetParameterFormatOptions(
ElementId^ parameterId
)
member GetParameterFormatOptions :
parameterId : ElementId -> FormatOptions
Parameters
- parameterId ElementId
-
Id of parameter for which FormatOptions will be returned.
Return Value
FormatOptions
Format options of element parameter. If the UseDefault property is true, then no formatting overrides have been defined in the element for the specified parameter, and the FormatOptions for the parameter should be obtained from the Unit object, which can be obtained from the Document.
Exceptions
See Also