Identifies if the element has been pinned to prevent changes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Pinned { get; set; }
Public Property Pinned As Boolean
Get
Set
public:
property bool Pinned {
bool get ();
void set (bool value);
}
member Pinned : bool with get, set
Property Value
Boolean
Exceptions
Remarks
An element which is pinned may not be moved, and warnings will be issued
when an attempt is made to delete it.
See Also