ElementChangeTypeId(ElementId) Method |
Changes the type of the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId ChangeTypeId(
ElementId typeId
)
Public Function ChangeTypeId (
typeId As ElementId
) As ElementId
public:
ElementId^ ChangeTypeId(
ElementId^ typeId
)
member ChangeTypeId :
typeId : ElementId -> ElementId
Parameters
- typeId ElementId
-
Identifier of the type to assign to this element.
Return Value
ElementId
The new element id if new element is created, or InvalidElementId if the element's type changed without creating a new element.
ExceptionsException | Condition |
---|
ArgumentException |
The type typeId is not valid for this element.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This Element cannot have type assigned.
|
ModificationForbiddenException |
This Element is an internal element, such as a component of a
loaded family or a group type.
-or-
The document containing this Element is in Group Edit Mode,
Sketch Edit Mode, or Paste Mode, and the element is not a
member of the group, sketch, or clipboard.
-or-
This Element is a member of a group or sketch, and the document
is not currently editing the group or sketch.
|
Remarks
In rare cases, applying a change in type will result in a new element being created.
The only active examples of this are when applying a normal wall type to a curtain panel, or
converting such a wall back to a curtain panel.
In this situation the new element id is returned.
Also, this element becomes invalid.
See also:
IsModifiable.
See Also