ElementGetExternalResourceReferencesExpanded Method |
Gets the expanded map of the external resource references referenced
by the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<ExternalResourceType, IList<ExternalResourceReference>> GetExternalResourceReferencesExpanded()
Public Function GetExternalResourceReferencesExpanded As IDictionary(Of ExternalResourceType, IList(Of ExternalResourceReference))
public:
IDictionary<ExternalResourceType^, IList<ExternalResourceReference^>^>^ GetExternalResourceReferencesExpanded()
member GetExternalResourceReferencesExpanded : unit -> IDictionary<ExternalResourceType, IList<ExternalResourceReference>>
Return Value
IDictionaryExternalResourceType,
IListExternalResourceReference
The expanded map of the external resource references referenced by the element.
Exceptions
Remarks
The value includes all external resource references under the type.
Use this API for an element which has multiple external resource references
under a specified type, e.g., AppearanceAssetElement.
See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferences].
See Also