ElementParameter(Guid) Property |
Retrieves a parameter from the element given a GUID for a shared parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Parameter this[
Guid guid
] { get; }
Public ReadOnly Property Parameter (
guid As Guid
) As Parameter
Get
public:
property Parameter^ Parameter[Guid guid] {
Parameter^ get (Guid guid);
}
member Parameter : Parameter with get
Parameters
- guid Guid
- The unique id associated with the shared parameter.
Property Value
Parameter
RemarksParameters are a generic form of data storage within elements. The parameters are visible
through the Autodesk Revit user interface in the Element Properties dialog. This method is used to
retrieve a parameter for a known shared parameter. When a shared parameter is created it is
assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the
element at a later time.
See Also