FabricationConfigurationLoadServices Method |
Loads the specified fabrication services into the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> LoadServices(
IList<int> serviceIds
)
Public Function LoadServices (
serviceIds As IList(Of Integer)
) As IList(Of Integer)
public:
IList<int>^ LoadServices(
IList<int>^ serviceIds
)
member LoadServices :
serviceIds : IList<int> -> IList<int>
Parameters
- serviceIds IListInt32
-
The identifiers of the fabrication services to load.
Return Value
IListInt32
The identifiers of the fabrication services which failed to load.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
-or-
this operation failed.
|
See Also