ElementVersionGuid Property |
Get the element version Guid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Guid VersionGuid { get; }
Public ReadOnly Property VersionGuid As Guid
Get
public:
property Guid VersionGuid {
Guid get ();
}
member VersionGuid : Guid with get
Property Value
Guid
ExceptionsException | Condition |
---|
InvalidOperationException |
When the Element is transient or when the Document has no version Guid for this Element.
|
Remarks
If element version Guid is the same for a certain element in two instances of the saved file
then we guarantee that the two elements are identical. One element version covers a period of time
that is larger than a single transaction: it is a period between two saves, synchronize to central and reload latest.
Thus, in an opened document in-between saves or synchronize actions,
this version cannot be used to determine if any particular element has changed. To watch for element changes happening in-session,
use event [!:Autodesk::Revit::ApplicationServices::Application::DocumentChanged].
See Also