FabricationConfigurationLoadItemFiles Method |
Loads the specified fabrication item files into the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<FabricationItemFile> LoadItemFiles(
IList<FabricationItemFile> itemFiles
)
Public Function LoadItemFiles (
itemFiles As IList(Of FabricationItemFile)
) As IList(Of FabricationItemFile)
public:
IList<FabricationItemFile^>^ LoadItemFiles(
IList<FabricationItemFile^>^ itemFiles
)
member LoadItemFiles :
itemFiles : IList<FabricationItemFile> -> IList<FabricationItemFile>
Parameters
- itemFiles IListFabricationItemFile
-
The relative paths of the fabrication item files to load.
Return Value
IListFabricationItemFile
The relative paths of the fabrication item files which failed to load.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
-or-
this operation failed.
|
See Also