FabricationConfigurationGetAllFabricationConnectorDefinitions Method |
Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetAllFabricationConnectorDefinitions(
ConnectorDomainType domain,
ConnectorProfileType shape
)
Public Function GetAllFabricationConnectorDefinitions (
domain As ConnectorDomainType,
shape As ConnectorProfileType
) As IList(Of Integer)
public:
IList<int>^ GetAllFabricationConnectorDefinitions(
ConnectorDomainType domain,
ConnectorProfileType shape
)
member GetAllFabricationConnectorDefinitions :
domain : ConnectorDomainType *
shape : ConnectorProfileType -> IList<int>
Parameters
- domain ConnectorDomainType
-
ConnectorDomainType to filter by. Pass ConnectorDomainType.Undefined to get all connector domains.
- shape ConnectorProfileType
-
ConnectorProfileType to filter by. Pass ConnectorProfileType.Invalid to get all shapes.
Return Value
IListInt32
All the fabrication connector identifiers, filtered by shape and domain. The return will be empty if no connectors are found.
Exceptions
See Also