FabricationConfigurationGetAncillaries Method |
Gets fabrication ancillaries of the specified type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetAncillaries(
FabricationAncillaryType type,
bool includeKits,
bool filterKits
)
Public Function GetAncillaries (
type As FabricationAncillaryType,
includeKits As Boolean,
filterKits As Boolean
) As IList(Of Integer)
public:
IList<int>^ GetAncillaries(
FabricationAncillaryType type,
bool includeKits,
bool filterKits
)
member GetAncillaries :
type : FabricationAncillaryType *
includeKits : bool *
filterKits : bool -> IList<int>
Parameters
- type FabricationAncillaryType
-
The type of ancillaries to get.
- includeKits Boolean
-
Whether or not to include ancillary kits as well.
- filterKits Boolean
-
Whether kits should be filtered to only those that contain the specified ancillary type.
Return Value
IListInt32
An array of ancillary identifiers.
Exceptions
See Also