EnergyDataSettings Class

This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.AnalysisEnergyDataSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EnergyDataSettings : Element

The EnergyDataSettings type exposes the following members.

Properties
 NameDescription
Public propertyAnalysisType The type of analysis mode.
Public propertyAnalyticalGridCellSize The cell size for the uniform cubical grid used when computing the building envelope
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyCode exampleBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyBuildingConstructionClass Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public propertyBuildingEnvelopeDeterminationMethod Indicates if an analysis should be perform to find the model elements that are part of the building envelope
Public propertyBuildingHVACSystem The type of HVAC system used by the building for conceptual model energy calculations.
Public propertyBuildingOperatingSchedule The operating schedule of the building used for conceptual model energy calculations.
Public propertyBuildingType The type of building.
Public propertyBuildingTypeId The building type element.
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCoreOffset The default offset used to determine the outer perimeter to be divided into zones.
Public propertyCreateAnalyticalModel If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public propertyCode exampleCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCode exampleDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyCode exampleDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDividePerimeter If this is true, zones with exterior boundaries on each floor of the building will be divided based on geometric criteria.
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyEnergyModel if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public propertyExportCategory Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public propertyExportComplexity Value determines Export Complexity for GreenBuildingXML detailed model export.
Public propertyExportDefaults Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
Public propertyCode exampleGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroundPlane Id of level which represents ground level.
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyCode exampleId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIncludeThermalProperties Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public propertyIsExportMullionsEnabled Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public propertyIsExportShadingSurfacesEnabled Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public propertyIsExportSimplifiedCurtainSystemsEnabled Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public propertyIsGlazingShaded If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyCode exampleLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyOutsideAirChangesRatePerHour The number of times the volume of air interchanges in the room in one hour.
Public propertyOutsideAirPerArea The rate of flow of outside air available per unit area.
Public propertyOutsideAirPerPerson The rate of flow of outside air available per person.
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyCode exampleParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyCode exampleParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPercentageGlazing Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public propertyPercentageSkylights Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyProjectPhase The project phase of the EnergyData information.
Public propertyProjectReportType Report type: None, simple, standard, detailed
Public propertyReportsFolder The folder path where all systems analysis reports are stored. It may include special label and relative path.
Public propertyServiceType The type of heating or cooling system.
Public propertyShadeDepth Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public propertySillHeight Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public propertySkylightWidth Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public propertySliverSpaceTolerance Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
Public propertyCode exampleUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyUseAirChangesPerHour True if user is specifying air changes per hour, false otherwise.
Public propertyUseCurrentViewOnly True if only elements visible in the currently active view are used for generation of Energy Model.
Public propertyUseHeatingCredits If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public propertyUseOutsideAirPerArea True is user is specifying outside air per area, false otherwise.
Public propertyUseOutsideAirPerPerson True if user is specifying outside air per person, false otherwise.
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodStatic memberCheckAnalysisType Checks that the analysis type falls within an appropriate range.
Public methodStatic memberCheckBuildingConstructionClass Checks that the building construction class falls within an appropriate range.
Public methodStatic memberCheckBuildingEnvelope Checks that the building envelope determination method falls within an appropriate range.
Public methodStatic memberCheckBuildingHVACSystem Checks that the building HVAC system falls within an appropriate range.
Public methodStatic memberCheckBuildingOperatingSchedule Checks that the building operating schedule falls within an appropriate range.
Public methodStatic memberCheckBuildingType Checks that the building type falls within an appropriate range.
Public methodCheckConstructionSetElement Checks that the construction set ElementId is acceptable.
Public methodStatic memberCheckExportCategory Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
Public methodStatic memberCheckExportComplexity Checks that the export complexity falls within an appropriate range.
Public methodCheckGroundPlane(ElementId) The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public methodStatic memberCheckGroundPlane(Document, ElementId) The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public methodCheckProjectPhase Checks that the input element is a project phase.
Public methodStatic memberCheckProjectReportType Checks that the project report type falls within an appropriate range.
Public methodStatic memberCheckRangeOfPercentageGlazing Checks that the percentage glazing value is between 0.00 and 0.95.
Public methodStatic memberCheckRangeOfPercentageSkylights Checks that the percentage skylights value is between 0.00 and 0.95.
Public methodStatic memberCheckRangeOfShadeDepth Checks that the shade depth is greater than or equal to zero.
Public methodStatic memberCheckRangeOfSillHeight Checks that the sill height is greater than or equal to zero.
Public methodStatic memberCheckRangeOfSkylightWidth Checks that the skylight width is greater than or equal to eight inches.
Public methodStatic memberCheckRangeOfSliverSpaceTolerance Checks that the sliver space tolerance is greater than or equal to zero.
Public methodStatic memberCheckServiceType Checks that the service type falls within an appropriate range.
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public methodStatic memberGetBuildingConstructionSetElementId Id of the building construction set.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodStatic memberGetFromDocument Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
Public methodCode exampleGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetReportsFolderParsed Gets the absolute reports folder path that is parsed from the original input.
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodCode exampleGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodStatic memberIsDocumentUsingEnergyDataAnalyticalModel Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetReportsFolder Sets the reports folder path.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Example
public void GetInfo_EnergyData(Document document)
{
   EnergyDataSettings energyData = EnergyDataSettings.GetFromDocument(document);

   if (null != energyData)
    {
        string message = "energyData : ";
        message += "\nBuildingType : " + energyData.BuildingType;
        TaskDialog.Show("Revit",message);
    }
}
See Also