EnergyDataSettings Class

This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.AnalysisEnergyDataSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EnergyDataSettings : Element

The EnergyDataSettings type exposes the following members.

Properties
 NameDescription
Public propertyAnalysisType The type of analysis mode.
Public propertyAnalyticalGridCellSize The cell size for the uniform cubical grid used when computing the building envelope
Public propertyBuildingConstructionClass Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public propertyBuildingEnvelopeDeterminationMethod Indicates if an analysis should be perform to find the model elements that are part of the building envelope
Public propertyBuildingHVACSystem The type of HVAC system used by the building for conceptual model energy calculations.
Public propertyBuildingOperatingSchedule The operating schedule of the building used for conceptual model energy calculations.
Public propertyBuildingType The type of building.
Public propertyBuildingTypeId The building type element.
Public propertyCoreOffset The default offset used to determine the outer perimeter to be divided into zones.
Public propertyCreateAnalyticalModel If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public propertyDividePerimeter If this is true, zones with exterior boundaries on each floor of the building will be divided based on geometric criteria.
Public propertyEnergyModel if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public propertyExportCategory Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public propertyExportComplexity Value determines Export Complexity for GreenBuildingXML detailed model export.
Public propertyExportDefaults Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
Public propertyGroundPlane Id of level which represents ground level.
Public propertyIncludeThermalProperties Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public propertyIsExportMullionsEnabled Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public propertyIsExportShadingSurfacesEnabled Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public propertyIsExportSimplifiedCurtainSystemsEnabled Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public propertyIsGlazingShaded If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public propertyOutsideAirChangesRatePerHour The number of times the volume of air interchanges in the room in one hour.
Public propertyOutsideAirPerArea The rate of flow of outside air available per unit area.
Public propertyOutsideAirPerPerson The rate of flow of outside air available per person.
Public propertyPercentageGlazing Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public propertyPercentageSkylights Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public propertyProjectPhase The project phase of the EnergyData information.
Public propertyProjectReportType Report type: None, simple, standard, detailed
Public propertyReportsFolder The folder path where all systems analysis reports are stored. It may include special label and relative path.
Public propertyServiceType The type of heating or cooling system.
Public propertyShadeDepth Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public propertySillHeight Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public propertySkylightWidth Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public propertySliverSpaceTolerance Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
Public propertyUseAirChangesPerHour True if user is specifying air changes per hour, false otherwise.
Public propertyUseCurrentViewOnly True if only elements visible in the currently active view are used for generation of Energy Model.
Public propertyUseHeatingCredits If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public propertyUseOutsideAirPerArea True is user is specifying outside air per area, false otherwise.
Public propertyUseOutsideAirPerPerson True if user is specifying outside air per person, false otherwise.
Top
Methods
 NameDescription
Public methodStatic memberCheckAnalysisType Checks that the analysis type falls within an appropriate range.
Public methodStatic memberCheckBuildingConstructionClass Checks that the building construction class falls within an appropriate range.
Public methodStatic memberCheckBuildingEnvelope Checks that the building envelope determination method falls within an appropriate range.
Public methodStatic memberCheckBuildingHVACSystem Checks that the building HVAC system falls within an appropriate range.
Public methodStatic memberCheckBuildingOperatingSchedule Checks that the building operating schedule falls within an appropriate range.
Public methodStatic memberCheckBuildingType Checks that the building type falls within an appropriate range.
Public methodCheckConstructionSetElement Checks that the construction set ElementId is acceptable.
Public methodStatic memberCheckExportCategory Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
Public methodStatic memberCheckExportComplexity Checks that the export complexity falls within an appropriate range.
Public methodCheckGroundPlane(ElementId) The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public methodStatic memberCheckGroundPlane(Document, ElementId) The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public methodCheckProjectPhase Checks that the input element is a project phase.
Public methodStatic memberCheckProjectReportType Checks that the project report type falls within an appropriate range.
Public methodStatic memberCheckRangeOfPercentageGlazing Checks that the percentage glazing value is between 0.00 and 0.95.
Public methodStatic memberCheckRangeOfPercentageSkylights Checks that the percentage skylights value is between 0.00 and 0.95.
Public methodStatic memberCheckRangeOfShadeDepth Checks that the shade depth is greater than or equal to zero.
Public methodStatic memberCheckRangeOfSillHeight Checks that the sill height is greater than or equal to zero.
Public methodStatic memberCheckRangeOfSkylightWidth Checks that the skylight width is greater than or equal to eight inches.
Public methodStatic memberCheckRangeOfSliverSpaceTolerance Checks that the sliver space tolerance is greater than or equal to zero.
Public methodStatic memberCheckServiceType Checks that the service type falls within an appropriate range.
Public methodStatic memberGetBuildingConstructionSetElementId Id of the building construction set.
Public methodStatic memberGetFromDocument Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
Public methodGetReportsFolderParsed Gets the absolute reports folder path that is parsed from the original input.
Public methodStatic memberIsDocumentUsingEnergyDataAnalyticalModel Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public methodSetReportsFolder Sets the reports folder path.
Top
Example
public void GetInfo_EnergyData(Document document)
{
   EnergyDataSettings energyData = EnergyDataSettings.GetFromDocument(document);

   if (null != energyData)
    {
        string message = "energyData : ";
        message += "\nBuildingType : " + energyData.BuildingType;
        TaskDialog.Show("Revit",message);
    }
}
See Also