EnergyDataSettingsCheckServiceType Method

Checks that the service type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CheckServiceType(
	gbXMLServiceType serviceType
)

Parameters

serviceType  gbXMLServiceType
The service type to be checked.

Return Value

Boolean
True if the service type falls within an appropriate range, false otherwise.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also