EnergyDataSettingsAnalysisType Property

The type of analysis mode.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AnalysisMode AnalysisType { get; set; }

Property Value

AnalysisMode
Exceptions
ExceptionCondition
ArgumentException When setting this property: The analysis type does not fall within an appropriate range.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also