EnergyDataSettingsGroundPlane Property |
Id of level which represents ground level.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GroundPlane { get; set; }
Public Property GroundPlane As ElementId
Get
Set
public:
property ElementId^ GroundPlane {
ElementId^ get ();
void set (ElementId^ value);
}
member GroundPlane : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The input element is not a level or invalidElementId.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
The ground plane defines what is above and below ground for Conceptual Energy Analysis.
The ground plane can optionally used for the rendering cast shadows.
See Also