EnergyDataSettingsCheckGroundPlane(ElementId) Method |
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CheckGroundPlane(
ElementId groundPlaneId
)
Public Function CheckGroundPlane (
groundPlaneId As ElementId
) As Boolean
public:
bool CheckGroundPlane(
ElementId^ groundPlaneId
)
member CheckGroundPlane :
groundPlaneId : ElementId -> bool
Parameters
- groundPlaneId ElementId
-
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or
that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".
Return Value
Boolean
True if the input element is a level or invalidElementId, false otherwise.
Exceptions
See Also