EnergyDataSettingsCoreOffset Property |
The default offset used to determine the outer perimeter to be divided into zones.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double CoreOffset { get; set; }
Public Property CoreOffset As Double
Get
Set
public:
property double CoreOffset {
double get ();
void set (double value);
}
member CoreOffset : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The given value for coreOffset must be between 0 and 30000 feet.
|
Remarks
A Zone can be either a Mass Zone or an Analytical Space depending on whether the AnalysisType is ConceptualMasses or otherwise.
Specifying a value here determines the zone depth and creates a core zone.
See Also