EnergyDataSettingsIsExportShadingSurfacesEnabled Property |
Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsExportShadingSurfacesEnabled { get; }
Public ReadOnly Property IsExportShadingSurfacesEnabled As Boolean
Get
public:
property bool IsExportShadingSurfacesEnabled {
bool get ();
}
member IsExportShadingSurfacesEnabled : bool with get
Property Value
Boolean
Remarks
Result is based on the ExportComplexity setting.
The method described by gbs/gbxml.org to calculate the shading surfaces is to
take all surfaces from the MEP spaces, subtract them from the surfaces from all building elements,
and then the remaining surfaces are considered to be the shading surfaces.
See Also