EnergyDataSettingsIsExportSimplifiedCurtainSystemsEnabled Property |
Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsExportSimplifiedCurtainSystemsEnabled { get; }
Public ReadOnly Property IsExportSimplifiedCurtainSystemsEnabled As Boolean
Get
public:
property bool IsExportSimplifiedCurtainSystemsEnabled {
bool get ();
}
member IsExportSimplifiedCurtainSystemsEnabled : bool with get
Property Value
Boolean
Remarks
Result is based on the ExportComplexity setting.
Curtain Walls and Curtain Systems are normally exported as multiple openings, panel by panel, while for
energy analysis this can be more simply represented as a single glass surface as large as the entire curtain wall/system.
Normally, a curtain wall with 50 panels would be exported as 50 openings. Often, exporting a single opening with
the total curtain system area is more appropriate. When this setting is on, one "large" window/opening will be
exported for a curtain wall/system.
See Also