EnergyDataSettingsBuildingType Property |
The type of building.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic gbXMLBuildingType BuildingType { get; set; }
Public Property BuildingType As gbXMLBuildingType
Get
Set
public:
property gbXMLBuildingType BuildingType {
gbXMLBuildingType get ();
void set (gbXMLBuildingType value);
}
member BuildingType : gbXMLBuildingType with get, set
Property Value
gbXMLBuildingType
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The building type does not fall within an appropriate range.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also