EnergyDataSettingsBuildingConstructionClass Property |
Used for both the detailed and conceptual energy model
Construction class of building as defined by:
loose, medium, tight, or none.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic HVACLoadConstructionClass BuildingConstructionClass { get; set; }
Public Property BuildingConstructionClass As HVACLoadConstructionClass
Get
Set
public:
property HVACLoadConstructionClass BuildingConstructionClass {
HVACLoadConstructionClass get ();
void set (HVACLoadConstructionClass value);
}
member BuildingConstructionClass : HVACLoadConstructionClass with get, set
Property Value
HVACLoadConstructionClass
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The building construction class does not fall within an appropriate range.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also