Rebar Class

Represents a rebar element in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureRebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Rebar : Element

The Rebar type exposes the following members.

Properties
 NameDescription
Public propertyCanHaveVaryingLengthBars Identifies if a set can have varying length bars or not.
Public propertyDistributionTypeObsolete.
The type of rebar distribution(also known as Rebar Set Type).
Public propertyHasVariableLengthBars Identifies if a set has varying length bars or not.
Public propertyIncludeFirstBar Identifies if the first bar in rebar set is shown.
Public propertyIncludeLastBar Identifies if the last bar in rebar set is shown.
Public propertyLayoutRule Identifies the layout rule of rebar set.
Public propertyMaxSpacing Identifies the maximum spacing between rebar in rebar set.
Public propertyNumberOfBarPositions The number of potential bars in the set.
Public propertyQuantity Identifies the number of bars in rebar set.
Public propertyReadOnlyParameters When set to true, Rebar will report all its parameters as read only. For example, the method Parameter::IsReadOnly() for all Rebar Parameters will return true. When set to false, the return value of Parameter::IsReadOnly() will not be affected.
Public propertyScheduleMark The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public propertyTotalLength The length of an individual bar multiplied by Quantity.
Public propertyVolume The volume of an individual bar multiplied by Quantity.
Top
Methods
 NameDescription
Public methodCanApplyPresentationMode Checks if a presentation mode can be applied for this rebar in the given view.
Public methodCanBeMatchedWithMultipleShapes Checks if this Rebar can be matched with multiple Rebar Shapes.
Public methodCanSuppressFirstOrLastBar Checks if the first or last bar in rebar set can be hidden in the given view.
Public methodCanUseHookType Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType
Public methodClearPresentationMode Sets the presentation mode for this rebar set to the default (either for a single view, or for all views).
Public methodConstraintsCanBeEdited

For ShapeDriven Rebar: returns true, if the Rebar element's external constraints are available for editing using the RebarConstraintsManager class. It will return false if Rebar is in Group

For FreeForm rebar: constraints can be edited if there is a valid external server Guid assigned to that Rebar

Public methodStatic memberContainsValidArcRadiiForStyleAndBarType Checks that all arcs in the chain of curves have radii that are not less than minimum bend radius for bar type and style
Public methodStatic memberCreateFreeForm(Document, Guid, RebarBarType, Element) Creates a free form rebar that can have constraints.
Public methodStatic memberCreateFreeForm(Document, RebarBarType, Element, IListCurveLoop, RebarFreeFormValidationResult) Creates a free form rebar that will be unconstrained. Constraints can't be added later to this rebar.
Public methodStatic memberCreateFreeForm(Document, RebarBarType, Element, IListIListCurve, RebarFreeFormValidationResult) Creates a free form rebar that will be unconstrained. Constraints can't be added later to this rebar.
Public methodStatic memberCode exampleCreateFromCurves(Document, RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IListCurve, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean) Creates a new instance of a shape driven Rebar element within the project.
Public methodStatic memberCreateFromCurves(Document, RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IListCurve, RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId, Boolean, Boolean) Creates a new instance of a shape driven Rebar element within the project.
Public methodStatic memberCreateFromCurvesAndShape(Document, RebarShape, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IListCurve, RebarHookOrientation, RebarHookOrientation) Creates a new instance of a shape driven Rebar element within the project. The instance will have the default shape parameters from the RebarShape. If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to true, then both the curves and hooks must match the RebarShape definition. Otherwise, the hooks can be different than the defaults specified in the RebarShape
Public methodStatic memberCreateFromCurvesAndShape(Document, RebarShape, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IListCurve, RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId) Creates a new instance of a shape driven Rebar element within the project. The instance will have the default shape parameters from the RebarShape. If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to true, then curves, hook types and hook rotation angles should match the rebar shape definition. Otherwise, the hooks can be different than the defaults specified in the RebarShape. If the RebarShapeDefinesEndTreatment flag in ReinforcementSettings has been set to true, then curves and end treatment types should match the rebar shape definition. Otherwise, the end treatment types can be different than the defaults specified in the RebarShape.
Public methodStatic memberCode exampleCreateFromRebarShape Creates a new shape driven Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public methodDoesBarExistAtPosition Checks whether a bar is included at the specified position.
Public methodEnableHookLengthOverride Enables or disables the ability to override hook lengths for this rebar instance.
Public methodFindMatchingPredefinedPresentationMode Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Public methodGetAllRebarShapeIds Gets the ids of the RebarShapes elements that defines the shapes of the rebar.
Public methodGetBarIndexFromReference Given a reference that represents a part of a bar, this method will return the bar index.
Public methodGetBendData Gets the RebarBendData, containing bar and hook information, of the instance.
Public methodGetCenterlineCurves A chain of curves representing the centerline of the rebar.
Public methodGetCouplerId Get the id of the Rebar Coupler that is applied to the rebar at the specified end.
Public methodCode exampleGetEndTreatmentTypeId Get the id of the EndTreatmentType to be applied to the rebar.
Public methodGetFreeFormAccessor Returns an interface providing access to free-form properties and methods for this Rebar element.
Public methodGetFullGeometryForView Generates full geometry for the Rebar for a specific view.
Public methodGetHookOrientation Returns the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Public methodGetHookRotationAngle Gets the out of plane hook rotation angle at the specified end.
Public methodGetHookTypeId Get the id of the RebarHookType to be applied to the rebar.
Public methodGetHostId The element that contains the rebar.
Public methodGetLapLength Gets the lap length that is used for the specified end - 0 for start, 1 for end.
Public methodGetMovedBarTransform Returns a transform representing the movement of the bar relative to its default position along the distribution path.
Public methodGetOverridableHookParameters Outputs the formula parameter ids defined in the RebarShape family which are associated with hook length and hook tangent length parameters.
Public methodGetParameterValueAtIndex Get the parameter value for a bar at the specified index.
Public methodGetPresentationMode Gets the presentation mode for this rebar set when displayed in the given view.
Public methodGetRebarConstraintsManager Returns an object for managing the external constraints on the Rebar element
Public methodGetRebarSplice Gets the rebar splice at the specified bar end - 0 for start, 1 for end.
Public methodGetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public methodGetShapeDrivenAccessor Returns an interface providing access to shape-driven properties and methods for this Rebar element.
Public methodGetShapeId Returns the id of the RebarShape element that defines the shape of the rebar.
Public methodGetSpliceStaggerLength Gets the stagger length that is used for the specified end - 0 for start, 1 for end.
Public methodGetTransformedCenterlineCurves A chain of curves representing the centerline of the rebar.
Public methodHasPresentationOverrides Identifies if this Rebar has overridden default presentation settings for the given view.
Public methodHookAngleMatchesRebarShapeDefinition Checks that the hook angle of the specified RebarHookType matches the hook angle used in the Rebar's RebarShape at the specified end of the bar.
Public methodIsBarHidden Identifies if a given bar in this rebar set is hidden in this view.
Public methodIsHookLengthOverrideEnabled Returns True if the ability to override hook lengths is enabled for this rebar instance, False otherwise.
Public methodIsRebarFreeForm Returns true if the rebar is free form and false if shape driven.
Public methodIsRebarInSection Identifies if this Rebar is cut by the view plane of the given view.
Public methodIsRebarShapeDriven Returns true if the rebar is shape driven and false if free form.
Public methodIsUnobscuredInView Checks if this rebar element is shown unobscured in a view.
Public methodMoveBarInSet This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.
Public methodStatic memberRebarShapeMatchesCurvesAndHooks Checks if rebarShape matches curves and hooks. If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to false, then this method will ignore the hook information.
Public methodStatic memberRebarShapeMatchesCurvesHooksAndEndTreatment Checks if rebarShape matches curves, hooks and end treatment. If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to false, then this method will ignore the hook information. If the RebarShapeDefinesEndTreatment flag in ReinforcementSettings has been set to false, then this method will ignore the end treatment information.
Public methodRemoveSplice Removes the splice relation at the specified end and all the Rebar Constraints involved in splice.
Public methodResetMovedBarTransform Reset the transformation representing the movement of the bar relative to its default position along the distribution path. The moved bar transform will be set to Identity.
Public methodSetBarHiddenStatus Sets the bar in this rebar set to be hidden or unhidden in the given view.
Public methodSetBarIncluded Sets if the bar at the desired index is included or not.
Public methodSetEndTreatmentTypeId Sets the id of the EndTreatmentType to be applied to the rebar. This can be done if and only if the end of the bar on which the end treatment is applied has no RebarCoupler on it, otherwise will throw an exception. If a RebarHookType is present at the rebar end, it will automatically set to invalidElementId.
Public methodSetHookOrientation Defines the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Public methodSetHookRotationAngle Sets the out of plane hook rotation angle at the specified end.
Public methodSetHookTypeId Set the id of the RebarHookType to be applied to the rebar. If an EndTreatmentType is present at the rebar end, it will automatically set to invalidElementId.
Public methodSetHostId The element that contains the rebar.
Public methodSetPresentationMode Sets the presentation mode for this rebar set when displayed in the given view.
Public methodSetUnobscuredInView Sets this rebar element to be shown unobscured in a view.
Top
Example
private void Getinfo_Rebar(Rebar rebar)
{
    string message = "Rebar: ";
    //get the bar type of the rebar
    message += "\nBar Type: " + (rebar.Document.GetElement(rebar.GetTypeId()) as RebarBarType).Name;

    //get the curve information
    IList<Curve> curves = rebar.GetCenterlineCurves(false, false, false, MultiplanarOption.IncludeOnlyPlanarCurves, 0);
    message += "\n\nThe Curves property has " + curves.Count + " curves:";
    foreach (Curve curve in curves)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.GetEndPoint(0).X + ", "
            + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", "
            + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    //get the host element of the rebar
    if (null != rebar.Document.GetElement(rebar.GetHostId())) //maybe some rebars don't have host
    {
        message += "\n\nThe host element ID : " + rebar.GetHostId().ToString();
    }

    TaskDialog.Show("Revit", message);
}
See Also