RebarGetFullGeometryForView Method |
Generates full geometry for the Rebar for a specific view.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic GeometryElement GetFullGeometryForView(
View view
)
Public Function GetFullGeometryForView (
view As View
) As GeometryElement
public:
GeometryElement^ GetFullGeometryForView(
View^ view
)
member GetFullGeometryForView :
view : View -> GeometryElement
Parameters
- view View
-
The view in which the geometry is generated.
Return Value
GeometryElement
The generated geometry of the Rebar before cutting is applied.
Exceptions
Remarks
The result of this method differs from Element.Geometry in that Element.Geometry will return
the rebar geometry cut by the view extents (such as the section box). In this method the entire Rebar geometry
is returned for the given view, before cutting.
See Also