RebarGetEndTreatmentTypeId Method |
Get the id of the EndTreatmentType to be applied to the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetEndTreatmentTypeId(
int end
)
Public Function GetEndTreatmentTypeId (
end As Integer
) As ElementId
public:
ElementId^ GetEndTreatmentTypeId(
int end
)
member GetEndTreatmentTypeId :
end : int -> ElementId
Parameters
- end Int32
-
0 for the start end treatment, 1 for the end end treatment.
Return Value
ElementId
The id of a EndTreatmentType, or invalidElementId if the rebar has
no end treatment at the specified end.
Exceptions
Exampleprivate void ListEndTreatments(Document doc, List<Rebar> bars)
{
StringBuilder info = new StringBuilder();
for (int n = 0; n < bars.Count; n++)
{
for (int i = 0; i < 2; i++)
{
ElementId treatmentTypeId = bars[n].GetEndTreatmentTypeId(i);
if (treatmentTypeId != ElementId.InvalidElementId)
{
EndTreatmentType treatmentType = doc.GetElement(treatmentTypeId) as EndTreatmentType;
info.AppendLine(string.Format("End treatment for bar {0} end {1}: {2}", n, i, treatmentType.EndTreatment));
}
}
}
TaskDialog.Show("Revit", info.ToString());
}
Private Sub ListEndTreatments(doc As Document, bars As List(Of Rebar))
Dim info As New StringBuilder()
For n As Integer = 0 To bars.Count - 1
For i As Integer = 0 To 1
Dim treatmentTypeId As ElementId = bars(n).GetEndTreatmentTypeId(i)
If treatmentTypeId <> ElementId.InvalidElementId Then
Dim treatmentType As EndTreatmentType = TryCast(doc.GetElement(treatmentTypeId), EndTreatmentType)
info.AppendLine(String.Format("End treatment for bar {0} end {1}: {2}", n, i, treatmentType.EndTreatment))
End If
Next
Next
TaskDialog.Show("Revit", info.ToString())
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also