RebarNumberOfBarPositions Property |
The number of potential bars in the set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int NumberOfBarPositions { get; set; }
Public Property NumberOfBarPositions As Integer
Get
Set
public:
property int NumberOfBarPositions {
int get ();
void set (int value);
}
member NumberOfBarPositions : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: the number of bar positions numberOfBarPositions is less than 1 or more than 1002.
|
InapplicableDataException |
When setting this property: This rebar element represents a single bar (the layout rule is Single).
|
Remarks
The number of positions is equal to the number of actual bars (the Quantity), plus the number of bars that are excluded.
See Also