Get the id of the Rebar Coupler that is applied to the rebar at the specified end.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetCouplerId(
int end
)
Public Function GetCouplerId (
end As Integer
) As ElementId
public:
ElementId^ GetCouplerId(
int end
)
member GetCouplerId :
end : int -> ElementId
Parameters
- end Int32
-
0 for the start Rebar Coupler, 1 for the end Rebar Coupler.
Return Value
ElementId
The id of a Rebar Coupler, or invalidElementId if the rebar has
no Rebar Coupler at the specified end.
Exceptions
See Also