RebarCanHaveVaryingLengthBars Property |
Identifies if a set can have varying length bars or not.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanHaveVaryingLengthBars { get; }
Public ReadOnly Property CanHaveVaryingLengthBars As Boolean
Get
public:
property bool CanHaveVaryingLengthBars {
bool get ();
}
member CanHaveVaryingLengthBars : bool with get
Property Value
Boolean
Remarks
This property is true if:
For free form rebar this will always be true.
- This is a free form rebar.
- This is a shape driven rebar for which the property Autodesk.Revit.DB.Structure.RebarShapeDrivenAccessor.UseRebarConstraintsToProduceVaryingBars is true.
- This is a shape driven rebar which has a splice stagger length different then 0 at least at one of the bar's ends.
Otherwise, is false.
See Also