RebarSetEndTreatmentTypeId Method

Sets the id of the EndTreatmentType to be applied to the rebar. This can be done if and only if the end of the bar on which the end treatment is applied has no RebarCoupler on it, otherwise will throw an exception. If a RebarHookType is present at the rebar end, it will automatically set to invalidElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetEndTreatmentTypeId(
	int end,
	ElementId endTreatmentTypeId
)

Parameters

end  Int32
0 for the start end treatment, 1 for the end end treatment.
endTreatmentTypeId  ElementId
The id of a EndTreatmentType element, or invalidElementId if the rebar should have no end treatment at the specified end.
Exceptions
ExceptionCondition
ArgumentException the parameter endTreatmentTypeId is not an EndTreatmentType element.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
InvalidOperationException the Rebar end end has a RebarCoupler on it.
See Also