RebarGetAllRebarShapeIds Method |
Gets the ids of the RebarShapes elements that defines the shapes of the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> GetAllRebarShapeIds()
Public Function GetAllRebarShapeIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetAllRebarShapeIds()
member GetAllRebarShapeIds : unit -> IList<ElementId>
Return Value
IListElementId
Returns the ids of the RebarShapes elements that defines the shapes of the rebar.
Remarks
If multiple bars in the set has the same shape id, this id will be reported only one in the resulted array.
See Also