RebarHookAngleMatchesRebarShapeDefinition Method |
Checks that the hook angle of the specified RebarHookType matches the hook angle used in the Rebar's RebarShape at the specified end of the bar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HookAngleMatchesRebarShapeDefinition(
int iEnd,
ElementId proposedHookId
)
Public Function HookAngleMatchesRebarShapeDefinition (
iEnd As Integer,
proposedHookId As ElementId
) As Boolean
public:
bool HookAngleMatchesRebarShapeDefinition(
int iEnd,
ElementId^ proposedHookId
)
member HookAngleMatchesRebarShapeDefinition :
iEnd : int *
proposedHookId : ElementId -> bool
Parameters
- iEnd Int32
-
0 for the start hook, 1 for the end hook.
- proposedHookId ElementId
-
The Id of the RebarHookType
Return Value
Boolean
Returns true if the hook angle of the RebarHookType matches the angle used in the RebarShape at the specified end of the bar.
Exceptions
Remarks
Also checks that the specified id is a valid RebarHookType.
If RebarShapeDefinesHooks property of ReinforcementSettings is false (European shapes), every valid hook angle matches RebarShape definition.
If RebarShapeDefinesHooks property of ReinforcementSettings is true (non-European shapes), hook angle matches RebarShape definition if it is null or equal RebarShape default hook angle.
See Also