RebarCanUseHookType Method |
Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanUseHookType(
ElementId proposedHookId
)
Public Function CanUseHookType (
proposedHookId As ElementId
) As Boolean
public:
bool CanUseHookType(
ElementId^ proposedHookId
)
member CanUseHookType :
proposedHookId : ElementId -> bool
Parameters
- proposedHookId ElementId
-
The Id of the RebarHookType
Return Value
Boolean
Returns true if the id is of a valid RebarHookType for the Rebar element.
Exceptions
Remarks
Also, checks that the Style of the Hook matches that of the Rebar's RebarShape
See Also