RebarGetParameterValueAtIndex Method |
Get the parameter value for a bar at the specified index.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ParameterValue GetParameterValueAtIndex(
ElementId paramId,
int barPositionIndex
)
Public Function GetParameterValueAtIndex (
paramId As ElementId,
barPositionIndex As Integer
) As ParameterValue
public:
ParameterValue^ GetParameterValueAtIndex(
ElementId^ paramId,
int barPositionIndex
)
member GetParameterValueAtIndex :
paramId : ElementId *
barPositionIndex : int -> ParameterValue
Parameters
- paramId ElementId
-
The parameter Id.
- barPositionIndex Int32
-
The bar index in the rebar distribution. Accepts only values between 0 and NumberOfBarPositions-1.
Return Value
ParameterValue
The ParameterValue for given parameterId and barPositionIndex.
Exceptions
Remarks
For rebar sets which don't have varying length bars the returned ParameterValue is the same no matter the index.
For rebar sets which have varying length bars the returned ParameterValue is evaluated at the given index.
See Also