RebarFindMatchingPredefinedPresentationMode Method |
Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarPresentationMode FindMatchingPredefinedPresentationMode(
View dBView
)
Public Function FindMatchingPredefinedPresentationMode (
dBView As View
) As RebarPresentationMode
public:
RebarPresentationMode FindMatchingPredefinedPresentationMode(
View^ dBView
)
member FindMatchingPredefinedPresentationMode :
dBView : View -> RebarPresentationMode
Parameters
- dBView View
-
The view.
Return Value
RebarPresentationMode
The presentation mode that matches the current set of selected hidden and unhidden bars.
If there is no better match, this returns RebarPresentationMode.Select.
Exceptions
Remarks
If the presentation mode is not PresentationMode.Select for the view, this function returns the current mode.
See Also