RebarGetHookOrientation Method |
Returns the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarHookOrientation GetHookOrientation(
int iEnd
)
Public Function GetHookOrientation (
iEnd As Integer
) As RebarHookOrientation
public:
RebarHookOrientation GetHookOrientation(
int iEnd
)
member GetHookOrientation :
iEnd : int -> RebarHookOrientation
Parameters
- iEnd Int32
-
0 for the start hook, 1 for the end hook.
Return Value
RebarHookOrientation
Value = Right: The hook is on your right as you stand at the end of the bar,
with the bar behind you, taking the bar's normal as "up."
Value = Left: The hook is on your left as you stand at the end of the bar,
with the bar behind you, taking the bar's normal as "up."
Exceptions
See Also