RebarGetHookTypeId Method |
Get the id of the RebarHookType to be applied to the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetHookTypeId(
int end
)
Public Function GetHookTypeId (
end As Integer
) As ElementId
public:
ElementId^ GetHookTypeId(
int end
)
member GetHookTypeId :
end : int -> ElementId
Parameters
- end Int32
-
0 for the start hook, 1 for the end hook.
Return Value
ElementId
The id of a RebarHookType, or invalidElementId if the rebar has
no hook at the specified end.
Exceptions
See Also